Форум Gatchina Online  

Вернуться   Форум Gatchina Online > Hard&Soft > Программы > Операционные системы

Ответ
 
Опции темы Опции просмотра
Старый 27.02.2006, 21:36   #1
FeD
модераст
 
Регистрация: 23.01.2006
Адрес: Въезд

Нарушения:[Посмотреть]
IP: 192.168.4.10
Windows 2000 Server ENG+ Apache&php

Имеется компутер с установленным Windows 2000 Server ENG, причём русского языка в системе вообще нету.... папки на флешке с русскими именами игнорируются.... No such dir, понимаешь ли
На этой машине установлен апач 1.3.34 и php 4.4.2 как CGI....
На веб-сервере лежит пара страниц html в кодировке Windows-1251 и они нормально выдаются сервером и всё путем. Но стоит запустить php-скрипт, написанный в той же кодировке, как апач виснет намертво просто... только завершение процесса помогает.......
Настройки веб-сервера абсолютно идентичные с моей машиной дома (Хп рус и 2003 сервер рус)... только на той машине винда установлена в папку C:\winnt\.
В связи с этим вопрос: в чём может быть причина такого поведения 2000 сервера?

ЗЫ. php.ini кинул в C:\winnt\
FeD вне форума   Ответить с цитированием
Старый 28.02.2006, 23:24   #2
Din-ngo
Гость
 

Нарушения:[Посмотреть]
IP: 192.168.55.7
phpinfo(); - тоже виснет?
  Ответить с цитированием
Старый 01.03.2006, 00:28   #3
FeD
модераст
 
Регистрация: 23.01.2006
Адрес: Въезд

Нарушения:[Посмотреть]
IP: 192.168.4.10
честно говоря, не пробовал....
но простецкий скрипт, который без проблем исполняется на другом сервере, но на русской винде там не работает... настройт 100% правильные... проверил уже 30 раз
FeD вне форума   Ответить с цитированием
Старый 01.03.2006, 20:16   #4
Din-ngo
Гость
 

Нарушения:[Посмотреть]
IP: 192.168.55.7
Ничего не понимаю в чем тыт фишка...

У меня тоже проблема имеется скрипт на моем компе все пашет, а на хостенге с етимже скриптом баги, и спрашивается почему. Даже сам себе могу ответить: ХЗ...
  Ответить с цитированием
Старый 01.03.2006, 23:26   #5
FeD
модераст
 
Регистрация: 23.01.2006
Адрес: Въезд

Нарушения:[Посмотреть]
IP: 192.168.4.10
ответ на мой вопрос оказался прост.... php.ini был слит в C:\winnt\ не тот, который php.ini-dist, а тот, который php.ini-recommended (по неосторожности) ну и там тольо register_globals было поверноуто в ON. Вот скрипты и не работали толком (самописные ). Стоило заменить его на тот, что php.ini-dist, как сразу всё стало летать....

в который раз уже наступаю на грабли в виде спешки...
FeD вне форума   Ответить с цитированием
Ответ


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы
Опции просмотра
Комбинированный вид Комбинированный вид

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Обновления для Windows XP Том Операционные системы 90 26.10.2009 20:49
Обновления для Windows 2003 Том Операционные системы 4 14.06.2007 21:00
MUI for Windows 2000 Server FeD Операционные системы 1 31.05.2006 11:25


Текущее время: 07:01. Часовой пояс GMT +4.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc. Перевод: zCarot